python-pymodis.spec 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. #
  2. # spec file for package pyModis (0.7.4)
  3. #
  4. # Copyright (c) 2014 Angelos Tzotsos <[email protected]>
  5. #
  6. # All modifications and additions to the file contributed by third parties
  7. # remain the property of their copyright owners, unless otherwise agreed
  8. # upon. The license for this file, and modifications and additions to the
  9. # file, is the same license as for the pyModis package itself (unless the
  10. # license for the pyModis package is not an Open Source License, in which
  11. # case the license is the MIT License). An "Open Source License" is a
  12. # license that conforms to the Open Source Definition (Version 1.9)
  13. # published by the Open Source Initiative.
  14. # Please submit bugfixes or comments via http://bugs.opensuse.org/
  15. #
  16. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  17. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  18. %define pyname pymodis
  19. %define pyname_cap pyModis
  20. Name: python-%{pyname}
  21. Version: 0.7.4
  22. Release: 0
  23. Summary: PyModis is a FOSS Python library to work with MODIS data
  24. License: GPLv2+
  25. Url: http://www.pymodis.org/
  26. Group: Productivity/Scientific/Other
  27. Source0: %{pyname_cap}-%{version}.tar.gz
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-build
  29. BuildArch: noarch
  30. BuildRequires: python-devel
  31. BuildRequires: python-setuptools
  32. BuildRequires: python-numpy
  33. BuildRequires: fdupes
  34. Requires: python
  35. Requires: python-numpy
  36. Requires: python-gdal
  37. %description
  38. PyModis is a Free and Open Source Python based library to work with MODIS data. It offers bulk-download for user selected time ranges, mosaicking of MODIS tiles, and the reprojection from Sinusoidal to other projections, convert HDF format to other formats
  39. %prep
  40. %setup -q -n %{pyname_cap}-%{version}
  41. %build
  42. %{__python} setup.py build
  43. %install
  44. rm -rf %{buildroot}
  45. python setup.py install --prefix=%{_prefix} --root=%{buildroot} \
  46. --record-rpm=INSTALLED_FILES
  47. %fdupes -s %{buildroot}
  48. %clean
  49. rm -rf %{buildroot}
  50. %files -f INSTALLED_FILES
  51. %defattr(-,root,root,-)
  52. %changelog